use strict;
my $str = '<img style="gdgdF" src="http://multimedia.pol.dk/archive/00802/RB_PLUS_Danskerne___802815p.jpg" width="369" height="253" alt="SPRITKONTROL" />';
my $regex = qr/<img.*src="(.*\)/ip;
my $subst = '<img src="http://multimedia.pol.dk/archive/00802/SNOOTS.jpg"';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";