import Foundation
let pattern = #"<img.*src="(.*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<img style="gdgdF" src="http://multimedia.pol.dk/archive/00802/RB_PLUS_Danskerne___802815p.jpg" width="369" height="253" alt="SPRITKONTROL" />"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img src="http://multimedia.pol.dk/archive/00802/SNOOTS.jpg""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}