#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/)|(http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/)"
Local $sString = "1.http://localhost:9001/f/" & @CRLF & _
"" & @CRLF & _
"2.http://localhost:9001/flight/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/" & @CRLF & _
"http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")