package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/)|(http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/)`)
var str = `1.http://localhost:9001/f/
2.http://localhost:9001/flight/
http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/
http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}