import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/flight\\/)|(http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/f\\/)";
final String string = "1.http://localhost:9001/f/\n\n"
+ "2.http://localhost:9001/flight/\n\n\n\n"
+ "http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/f\\/\n"
+ "http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/flight\\/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}