$re = '/(http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/)|(http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/)/';
$str = '1.http://localhost:9001/f/
2.http://localhost:9001/flight/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/f\\/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/flight\\/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);