const regex = /(http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/)|(http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]{0,1}:\\\/\\\/localhost:[0-9]{4}\\\/flight\\\/)|(http[s]{0,1}:\\\/\\\/localhost:[0-9]{4}\\\/f\\\/)', 'g')
const str = `1.http://localhost:9001/f/
2.http://localhost:9001/flight/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/f\\/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/flight\\/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}