re = /(http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/)|(http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/)/
str = '1.http://localhost:9001/f/
2.http://localhost:9001/flight/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/f\\/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/flight\\/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end