import Foundation
let pattern = #"(http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/)|(http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1.http://localhost:9001/f/
2.http://localhost:9001/flight/
http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/
http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)