// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http[s]{0,1}:\/\/localhost:[0-9]{4}\/flight\/)|(http[s]{0,1}:\/\/localhost:[0-9]{4}\/f\/)").unwrap();
let string = "1.http://localhost:9001/f/
2.http://localhost:9001/flight/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/f\\/
http[s]{0,1}:\\/\\/localhost:[0-9]{4}\\/flight\\/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}