#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "'file' *: *'([^']*)'"
Local $sString = "<script type="text/javascript">" & @CRLF & _
" jwplayer('player_container').setup(" & @CRLF & _
" { " & @CRLF & _
" 'width': '640', " & @CRLF & _
" 'height': '384'," & @CRLF & _
" 'players': [ {type: 'flash', src: '/player/player.swf'} ]," & @CRLF & _
" 'file':'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4'," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")