using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'file' *: *'([^']*)'";
string input = @"<script type=""text/javascript"">
jwplayer('player_container').setup(
{
'width': '640',
'height': '384',
'players': [ {type: 'flash', src: '/player/player.swf'} ],
'file':'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4',
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}