# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"'file' *: *'([^']*)'"
test_str = ("<script type=\"text/javascript\">\n"
" jwplayer('player_container').setup(\n"
" { \n"
" 'width': '640', \n"
" 'height': '384',\n"
" 'players': [ {type: 'flash', src: '/player/player.swf'} ],\n"
" 'file':'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4',\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.