$re = '/\'file\' *: *\'([^\']*)\'/';
$str = '<script type="text/javascript">
jwplayer(\'player_container\').setup(
{
\'width\': \'640\',
\'height\': \'384\',
\'players\': [ {type: \'flash\', src: \'/player/player.swf\'} ],
\'file\':\'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4\',
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);