import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'file' *: *'([^']*)'";
final String string = "<script type=\"text/javascript\">\n"
+ " jwplayer('player_container').setup(\n"
+ " { \n"
+ " 'width': '640', \n"
+ " 'height': '384',\n"
+ " 'players': [ {type: 'flash', src: '/player/player.swf'} ],\n"
+ " 'file':'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4',\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}