import Foundation
let pattern = #"'file' *: *'([^']*)'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<script type="text/javascript">
jwplayer('player_container').setup(
{
'width': '640',
'height': '384',
'players': [ {type: 'flash', src: '/player/player.swf'} ],
'file':'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4',
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}