use strict;
my $str = '<script type="text/javascript">
jwplayer(\'player_container\').setup(
{
\'width\': \'640\',
\'height\': \'384\',
\'players\': [ {type: \'flash\', src: \'/player/player.swf\'} ],
\'file\':\'http://video.sibnet.ru/v/98a6a9525d30afd623457f445ca95199/1321852.mp4\',
';
my $regex = qr/'file' *: *'([^']*)'/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}