#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$?(\d+(?:\s\d+)*(?:[\.\,]\d{1,2})?)\s?\$?$"
Local $sString = "12,00$" & @CRLF & _
"122.04$" & @CRLF & _
"12123123" & @CRLF & _
"1 200$" & @CRLF & _
"1 200,22$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")