re = /^\$?(\d+(?:\s\d+)*(?:[\.\,]\d{1,2})?)\s?\$?$/m
str = '12,00$
122.04$
12123123
1 200$
1 200,22$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end