package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\$?(\d+(?:\s\d+)*(?:[\.\,]\d{1,2})?)\s?\$?$`)
var str = `12,00$
122.04$
12123123
1 200$
1 200,22$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}