import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$?(\\d+(?:\\s\\d+)*(?:[\\.\\,]\\d{1,2})?)\\s?\\$?$";
final String string = "12,00$\n"
+ "122.04$\n"
+ "12123123\n"
+ "1 200$\n"
+ "1 200,22$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}