$re = '/^\$?(\d+(?:\s\d+)*(?:[\.\,]\d{1,2})?)\s?\$?$/m';
$str = '12,00$
122.04$
12123123
1 200$
1 200,22$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);