import re
regex = re.compile(r"^\$?(\d+(?:\s\d+)*(?:[\.\,]\d{1,2})?)\s?\$?$", flags=re.MULTILINE)
test_str = ("12,00$\n"
"122.04$\n"
"12123123\n"
"1 200$\n"
"1 200,22$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")