// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\$?(\d+(?:\s\d+)*(?:[\.\,]\d{1,2})?)\s?\$?$").unwrap();
let string = "12,00$
122.04$
12123123
1 200$
1 200,22$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}