#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\d*)(?: ?до| руб\.) (\d*)(?: руб\. )?\/ (ч|\d+)"
Local $sString = "от 1100 руб. / ч" & @CRLF & _
"до 1900 руб. / 45 мин." & @CRLF & _
"от 1200 до 1900 руб. / 90 мин. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")