import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*)(?: ?до| руб\\.) (\\d*)(?: руб\\. )?\\/ (ч|\\d+)";
final String string = "от 1100 руб. / ч\n"
+ "до 1900 руб. / 45 мин.\n"
+ "от 1200 до 1900 руб. / 90 мин. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}