// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\d*)(?: ?до| руб\.) (\d*)(?: руб\. )?\/ (ч|\d+)").unwrap();
let string = "от 1100 руб. / ч
до 1900 руб. / 45 мин.
от 1200 до 1900 руб. / 90 мин. ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}