re = /(\d*)(?: ?до| руб\.) (\d*)(?: руб\. )?\/ (ч|\d+)/mi
str = 'от 1100 руб. / ч
до 1900 руб. / 45 мин.
от 1200 до 1900 руб. / 90 мин. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end