const regex = /(\d*)(?: ?до| руб\.) (\d*)(?: руб\. )?\/ (ч|\d+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)(?: ?до| руб\\.) (\\d*)(?: руб\\. )?\\\/ (ч|\\d+)', 'gmi')
const str = `от 1100 руб. / ч
до 1900 руб. / 45 мин.
от 1200 до 1900 руб. / 90 мин. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}