$re = '/(\d*)(?: ?до| руб\.) (\d*)(?: руб\. )?\/ (ч|\d+)/mi';
$str = 'от 1100 руб. / ч
до 1900 руб. / 45 мин.
от 1200 до 1900 руб. / 90 мин. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);