import re
regex = re.compile(r"(\d*)(?: ?до| руб\.) (\d*)(?: руб\. )?\/ (ч|\d+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("от 1100 руб. / ч\n"
"до 1900 руб. / 45 мин.\n"
"от 1200 до 1900 руб. / 90 мин. ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")