# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\@([\w]+\.)?cyber(folks|stores)\.(pl|com|ro|hr)|([\w\W]+\.)?emaillabs\.net\.pl|((local|sp|local-\d+\.cyberadmin)\.)?cyber\-folks\.pl|([\w\W]+\.)?livemailservice\.com|ascio\.com|cfpl\.atlassian\.net|mlsend\.com|satisfactia\.com|zenbox\.pl|avalon\.hr|hekko(\.net)?\.pl|futurehost\.pl|linuxpl\.com//;t' <<< "jira@cfpl.atlassian.net"