const regex = /\@([\w]+\.)?cyber(folks|stores)\.(pl|com|ro|hr)|([\w\W]+\.)?emaillabs\.net\.pl|((local|sp|local-\d+\.cyberadmin)\.)?cyber\-folks\.pl|([\w\W]+\.)?livemailservice\.com|ascio\.com|cfpl\.atlassian\.net|mlsend\.com|satisfactia\.com|zenbox\.pl|avalon\.hr|hekko(\.net)?\.pl|futurehost\.pl|linuxpl\.com/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\@([\\w]+\\.)?cyber(folks|stores)\\.(pl|com|ro|hr)|([\\w\\W]+\\.)?emaillabs\\.net\\.pl|((local|sp|local-\\d+\\.cyberadmin)\\.)?cyber\\-folks\\.pl|([\\w\\W]+\\.)?livemailservice\\.com|ascio\\.com|cfpl\\.atlassian\\.net|mlsend\\.com|satisfactia\\.com|zenbox\\.pl|avalon\\.hr|hekko(\\.net)?\\.pl|futurehost\\.pl|linuxpl\\.com', '')
const str = `jira@cfpl.atlassian.net`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);