use strict;
my $str = 'jira@cfpl.atlassian.net';
my $regex = qr/\@([\w]+\.)?cyber(folks|stores)\.(pl|com|ro|hr)|([\w\W]+\.)?emaillabs\.net\.pl|((local|sp|local-\d+\.cyberadmin)\.)?cyber\-folks\.pl|([\w\W]+\.)?livemailservice\.com|ascio\.com|cfpl\.atlassian\.net|mlsend\.com|satisfactia\.com|zenbox\.pl|avalon\.hr|hekko(\.net)?\.pl|futurehost\.pl|linuxpl\.com/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";