import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\@([\\w]+\\.)?cyber(folks|stores)\\.(pl|com|ro|hr)|([\\w\\W]+\\.)?emaillabs\\.net\\.pl|((local|sp|local-\\d+\\.cyberadmin)\\.)?cyber\\-folks\\.pl|([\\w\\W]+\\.)?livemailservice\\.com|ascio\\.com|cfpl\\.atlassian\\.net|mlsend\\.com|satisfactia\\.com|zenbox\\.pl|avalon\\.hr|hekko(\\.net)?\\.pl|futurehost\\.pl|linuxpl\\.com";
final String string = "jira@cfpl.atlassian.net";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}