$re = '/\@([\w]+\.)?cyber(folks|stores)\.(pl|com|ro|hr)|([\w\W]+\.)?emaillabs\.net\.pl|((local|sp|local-\d+\.cyberadmin)\.)?cyber\-folks\.pl|([\w\W]+\.)?livemailservice\.com|ascio\.com|cfpl\.atlassian\.net|mlsend\.com|satisfactia\.com|zenbox\.pl|avalon\.hr|hekko(\.net)?\.pl|futurehost\.pl|linuxpl\.com/';
$str = 'jira@cfpl.atlassian.net';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;