using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\@([\w]+\.)?cyber(folks|stores)\.(pl|com|ro|hr)|([\w\W]+\.)?emaillabs\.net\.pl|((local|sp|local-\d+\.cyberadmin)\.)?cyber\-folks\.pl|([\w\W]+\.)?livemailservice\.com|ascio\.com|cfpl\.atlassian\.net|mlsend\.com|satisfactia\.com|zenbox\.pl|avalon\.hr|hekko(\.net)?\.pl|futurehost\.pl|linuxpl\.com";
string substitution = @"";
string input = @"jira@cfpl.atlassian.net";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}