# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*[^a-z \n].*$//gim;t' <<< "chocolate milk - 50 gallons
Milk - 50 Gallonsgi
Milk 50 gallons"