using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*[^a-z \n].*$";
string substitution = @"";
string input = @"chocolate milk - 50 gallons
Milk - 50 Gallonsgi
Milk 50 gallons";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}