// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\s*[^a-z \n].*$").unwrap();
let string = "chocolate milk - 50 gallons
Milk - 50 Gallonsgi
Milk 50 gallons";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}