package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\s*[^a-z \n].*$`)
var str = `chocolate milk - 50 gallons
Milk - 50 Gallonsgi
Milk 50 gallons`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}