$re = '/\s*[^a-z \n].*$/im';
$str = 'chocolate milk - 50 gallons
Milk - 50 Gallonsgi
Milk 50 gallons';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;