use strict;
my $str = 'chocolate milk - 50 gallons
Milk - 50 Gallonsgi
Milk 50 gallons';
my $regex = qr/\s*[^a-z \n].*$/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";