re = /\s*[^a-z \n].*$/im
str = 'chocolate milk - 50 gallons
Milk - 50 Gallonsgi
Milk 50 gallons'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result