#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\s*[^a-z \n].*$"
Local $sString = "chocolate milk - 50 gallons" & @CRLF & _
"Milk - 50 Gallonsgi" & @CRLF & _
"Milk 50 gallons"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)