# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)//gm;t' <<< "hello#music
#hello#music
hello.com#music -> no match"