re = /^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)/m
str = 'hello#music
#hello#music
hello.com#music -> no match'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result