using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)";
string substitution = @"";
string input = @"hello#music
#hello#music
hello.com#music -> no match";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}