#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)"
Local $sString = "hello#music" & @CRLF & _
"#hello#music" & @CRLF & _
"hello.com#music -> no match"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)