use strict;
my $str = 'hello#music
#hello#music
hello.com#music -> no match';
my $regex = qr/^(?!.*?\.).*?(#.*\w*[a-zA-Z_]+\w*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";